Friday, February 23, 2018

#OpsMgr 1801 Upgrade issue

caution_warning_sign_sticker-650x800Ran into an issue with the upgrade from OpsMgr 2016 to 1801 with one of my customers recently, and I thought I would share it.

For some reason, they only installed .Net 4 on their management servers, and did not have .Net 3.5 installed.

Turns out the installation requires .Net 3.5 to be installed on the management servers, and, despite the prereq check returning no errors, the installation fails on the Management Server component with the following error reported in the install log:

Error:     :LaunchMSI: MSI C:\System Center Operations Manager\Setup\AMD64\Server\OMServer.msi returned error 1603

The installation then rolls back, which uninstalls all OpsMgr components on the management server.

If you then try to rerun the installation, it will fail on the database selection screen with an error that it cannot connect to the instance/find the database, but when you look in the Install log the error states that the management server already exists in the database and a recovery is not possible at this time.

You will need to recover the database, remove the management server from the management group and reinstall it to recover.


So, before you upgrade, make sure you take a full backup of the OperationsManager database, and make sure .Net 3.5 has been installed on all management servers.

ps: I am sorry for shamelessly nicking pictures off the interwebs for this post. If these belong to you, please let me know.


cola kriel said...

but is 3.5 not one of the pre req's as i normally install it always. good blog as always. We are also looking to move to 1801

cola kriel said...

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:d:\sources\sxs

for those who will need to google it. just run CMD in elevated mode.

Related Posts with Thumbnails